Investigating issues with email delays

Incident Report for OpenNode

Resolved

This incident has been resolved.
Posted Dec 17, 2022 - 16:06 UTC

Identified

Emails are still being sent and delivered but with significant delays due to an issue our provider.
Posted Dec 16, 2022 - 23:56 UTC